Chevy Cobalt Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi everyone, Thank you for taking the time to read. I recently purchased a 2007 Chevy cobalt LS at 41k miles an it drives nice but recently I've been feeling this weird feeling kindakn the gas pedal around 1500 rpm. I'll be doing 40-50 mph an be sitting around 2k rpm am without me backing off the gas the rpm gauge will come down to around 1500 an just sit there an then that's when the feeling starts. When it happens I can press the gas pedal half way to the floor without the rpm moving from 1500rpm then it jumps up to 3500-4000 rpm.
 

·
Registered
Joined
·
438 Posts
Kind of odd for such low mileage really. It could be many things. The car was probably used for very short trips which isn’t the best thing for the car. I have a feeling you or the previous owner has not serviced the transmission by doing a fluid and filter change.

This transmission is hydraulic with electronically controlled components. It really could be a number of things causing thing. Hydraulic pressure has to be maintained for the transmission to work correctly. If the fluid is low, it can cause something like this. Also problems in the valve body cause cause this sort of thing. It’s hard to say exactly what it is.

I would recommend to have it looked at by a transmission shop, or mechanic that is familiar with transmission repair. If I was going to recommend anything to start with, it would be servicing it with new fluid and filter. Also checking for leaks at this time.

When the problem occurs, does it seem like the engine just free revs as if it’s in neutral?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I took it to a transmission shop yesterday an He said it's most likely the tcc flutter valve. Said it wouldn't harm the vehicle. The car bogs down a little when it happens.
 

·
Registered
Joined
·
438 Posts
I believe you might mean the torque converter lock up solenoid. And he meant it is causing it to flutter. My car does this occasionally, but rpms don’t go too far. Usually will do this between 36-42 mph. But otherwise mine won’t do it at other speeds.

After I did a fluid and filter service on my transmission it hasn’t been doing it much. I really can’t remember the last time it gave me any problems since doing the service.
 
1 - 4 of 4 Posts
Top