Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 17 of 17 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
hey there guys clearly im new to the forum (first post)
i jus bought a cobalt!
very happy with the car ahah
but two isues, when i come to a stop the idle drops to below 500rpm and acts like its going to stall, but it has not stalled and after it drops it come back up and idles fine... so it only happens once i stop.

next question is, when doing 100-140, the stearing wheel shakes a little and has a little vibration?

let me know guys thanks!
 

·
Registered
Joined
·
2,969 Posts
1st question happens to me to. I'm trying to figure it out

2nd question, check your lugs nuts

---------- Post added at 10:37 PM ---------- Previous post was at 10:36 PM ----------

100-140 kmh right? Not mph?
 

·
Registered
Joined
·
183 Posts
Discussion Starter #4
ok ill check the wheels ext,
and yea its not standard so im real baffled on ewhy thats happening and if its a seriour problem or not.... it has 145km and im not sure if the guy or girl before me ever did a tune up or not could this be te casue?

---------- Post added at 06:45 AM ---------- Previous post was at 06:45 AM ----------

and yes kmh not mph haha
 

·
Not justice...Punishment
Joined
·
3,829 Posts
Yes, it could be the car needs a tune up. 145,000 km is 90,000 miles. Your plugs are due at 100,000 miles. You might want to change them, and the wires, oil change, air filter, then see what you got.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #8
ok will do!
hope it helps its just super anoying!
lol
i only payed 3000gs for the car though!
so thats a bonus
 

·
Registered
Joined
·
911 Posts
where in Canada u from? Welcome to the site and hope u find out whats wrong and get it fixed for cheap \m/
 

·
Premium Member
Joined
·
1,044 Posts
1. most cobalts do that. the engine load on these cars is super gay... try boosting the car it makes the issue more pronounced...

2. alignment or wheel balancing should fix it.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #13
boosting it?
what the hell does that mean?
it starts fine ahha
 

·
Registered
Joined
·
1,115 Posts
#1 Mine does it, have your OBD-2 port looked at at your local automotive retailer...mine is throwing a Lean System code on my upflow O2 Sensor...I'd see what codes it throws before you do anything, spark plugs are cheap too, I'd suggest replacing them as well, it cant hurt.
 
1 - 17 of 17 Posts
Status
Not open for further replies.
Top