Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 20 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
My car is misfiring horribly sometimes, along with what sounds like piston knock coming from the right side of the block. Im getting the codes, p0010 (intake cam positioning solenoid bank 1)(symptom 00), p0011 intake cam performance bank 1(symptom 00), and p0420 catalyst efficientcy low (symptom 00). I know its not the sensor, or could it? Some info about the car: Awhile ago my flex piece broke and eventually I was driving without an exhaust system for 2 or so months. Then I fixed it and replaced the cat with an eaton downpipe. Its a 2009 LT. Any suggestions anyone?
 

·
Super Moderator
Joined
·
11,821 Posts
It would suprise me if it was bank 2....The Cobalt only has one bank. P0010 and P0011 are being set because cam actuator cannot attain the ECM demanded adjustement to compensate for the inefficient cat. P0420 is usually because you have an exhaust leak between the 2 HO2 sensor. But you're saying that was all replaced by what I assume is a cheap replacement cat. Cat is probably not compatible with your Cobalt. Going the cheap way is not always the cheapest if you have to do it twice.
 

·
Super Moderator
Joined
·
11,821 Posts
It means your second HO2 sensor expects a certain amount of oxygen in the exhaust after these have gone through the cat compared to the first HO2 readings.When there's too much difference the ECM tries to compensate by enriching or leaning fuel mixture and by trying to advance cam position to accommodate this data. If re-calibration falls out of limit you will get codes.
 

·
Super Moderator
Joined
·
11,821 Posts
Are you sure you don't have a leak between both sensors?
 

·
Registered
Joined
·
60 Posts
Discussion Starter #7
Yeah, I put it on a lift and did a safety check when I bumped another car the other day. You'd be able to hear it wouldnt you?
 

·
Levee
Joined
·
3,210 Posts
Yeah, I put it on a lift and did a safety check when I bumped another car the other day. You'd be able to hear it wouldnt you?
Most of the time yes. Sometimes you have to smoke the exhaust to see it (using a fogger into your exhaust to see if it leaks from anywhere). lol. I know with my balt when I had a catless exhaust I had to disable the P0420 code (obviously). Sounds to me like the cat on your car (like Coby said) is not working the way it should for the cobalt.

Random question, did they change your 02 sensors with the new cat being put on or did they just re-use the old ones? If they re-used the old ones, I'm almost willing to bet they are bad now.
 

·
Levee
Joined
·
3,210 Posts
might be on to something here lol. I know you have to use a torch to get them out 99% of the time, and when you put that kind of heat on them, they don't like to work very well after that.
 

·
Super Moderator
Joined
·
11,821 Posts
But he's got no HO2 codes!!!!
 

·
Registered
Joined
·
60 Posts
Discussion Starter #12
Im gonna start replacing a few things and checking my exhaust system thoroughly. If that doesn't help, ill start saving up for a zzp downpipe.
 

·
Super Moderator
Joined
·
11,821 Posts
nope, you need to post the url
 

·
Registered
Joined
·
1,067 Posts
Levee you know everything.
I see " who wants to be a millionaire"
In your future.
I have connections, I'll get you in if you do me a favor
 

·
Super Moderator
Joined
·
11,821 Posts
Most definitely not a good sound. Kinda sounds like bieniki engine. He spun a connecting rod bearing.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #19
If it was running dangerously horribly maybe. I think its more alot the line of a lifter stuck or something. If im gentle enough could I re use the valve cover gasket?
 

·
Levee
Joined
·
3,210 Posts
But he's got no HO2 codes!!!!
If your 02 sensor is getting the wrong readings it will post a 0420 code. I know this because it is the same code that pops up when you go catless. Everything in the cat could be working fine, but if his old cat clogged the 02 sensor it will still get readings but they will be wrong. Thus when they are wrong they will set the 0420 code. Seen this a hundred times.

Levee you know everything.
I see " who wants to be a millionaire"
In your future.
I have connections, I'll get you in if you do me a favor
Depends on this favor and I don't know everything, just most things lol:idea:

If it was running dangerously horribly maybe. I think its more alot the line of a lifter stuck or something. If im gentle enough could I re use the valve cover gasket?
Sounds like a lifter, but you need to see if it is coming from the top end (it sounds like it is) or the bottom end. Have you checked your timing chain tesnioner? Could be your timing chain slapping around in there too.
 
1 - 20 of 20 Posts
Status
Not open for further replies.
Top