Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
A couple of weeks ago I blew the engine on my car so I went to go look for another one at the junk yard and I found one took it home and started to take out the old engine well I noticed that the engine I got from the juke yard had two plugs on the top of the engine where two senors go and the engine that I blew didn't have those also the vaule cover on my engine just says ecotec and the other one says ecotec vvt what the difference well this engine fit my car or is it a different engine.
 

·
Registered
Joined
·
821 Posts
Hmmmm? *raises a peoples eyebrow
 

·
Registered
Joined
·
872 Posts
My 2.2 LAP also has the VVT. :blink1:

---------- Post added at 05:39 PM ---------- Previous post was at 05:38 PM ----------



:patsmarioontheback:
:laugh:
Yea i kno lol but to my knowledge the lap doesnt have vvt on the valve cover, which is y i assumed it was the le5
 

·
Premium Member
Joined
·
1,044 Posts
how many psi u running and wut tuning? im assuming since its a garrett u stuck with that?

also when pulling the motor u should've seen the culprit. did u blow a rod or piston? oil starving?


im running wut should be 300-330whp thru mine and its been great
 

·
Registered
Joined
·
58 Posts
Discussion Starter #17
I was running 8 psi and I think it was a rod in one of the pics u can see that the whole piston and rod is missing but I wish I knew y it blew that way I won't make the same mistake twice
 

·
Registered
Joined
·
6,103 Posts
1 - 20 of 21 Posts
Status
Not open for further replies.
Top