Chevy Cobalt Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
106 Posts
Discussion Starter #1
So ive spent the last month diagnosing and trouble shooting my drivers side heated seat. In case you dont know, GM found a way to make heated seats a complex system that is wired into the BCM and controlled with 2 separate control modules underneath each of the seats. My passenger side heated seat system worked fine, you could measure 12+ volts at the connector going in from the switch to the control module, and 12+ volts being output by the lower cushion which is wired in line with the back cushion.

The drivers side however was only putting out 6.5v consistently on high or low power modes. Turns out the reason for this was damaged to the lower heating element, which contains not only resistors but a variable rheostat which the control module under the seat uses to regulate temperature. 6.5v is what is considered "low power mode" when the module detects that the pad has reached the desired temp. Any fault in this system and it doesnt work right. Strangely enough the switch does not thrown any indicator that there is a problem. (the switch will flash if the control module detects and under temp or overtemp condition apparently).

So i had to take the entire seat apart, and heres what I found.



the lower cushion is held on with 4 bolts underneath the seat rail, removing the lower cushion makes this job a whole lot easier without the need to disassemble the entire seat.




Here you can see where the element finally burned out from what i can only assume is a fault in the systems voltage regulation. The lower element is 60 dollars from GM, it is the more expensive of the two elements because it contains the entire wiring harness.

Here is a shot of the control module which is under the front of each seat.





And for future diagnosis problems, both wiring schematics...


 

·
Registered
Joined
·
45 Posts
Great write up. I have the same problem. Passenger side heats driver side does not. I wasn't easily able to get the leather off and stopped trying before I screwed something up. Where the creases in the seat are looks to be some kind of plastic that I guess makes the creases, not real sure. I couldn't seem to pull the covering off the foam and just gave up on that. Any suggestions would be great. I would love to get the seat working again.
 

·
Registered
Joined
·
106 Posts
Discussion Starter #3
On the newer cobalts the seems are velcroed but on my car the leather cover has a channel or rail that is held in with clips that are built into the foam cushion. You just have to work them out like you would a regular clip, then reinstall is easy, just push the rail back down into the opening of the clip with your finger pushing from the bottom of the clip, you can feel a recessed hole in the bottom of the cushion you can use to push on.

 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top